回覆列表
  • 1 # 今天也要完成目標哦

    題主沒給出具體裝置。如果在windows系統下,route -p add xxxx mask nnnn iiii。引數-p是永久的,不加的話,重啟就消失。xxx代表目標地址或地址段,nnn是掩碼,配合地址或地址段,最後的iii代表你的下一跳。舉例:你的地址是10.240.0.68,掩碼255.255.255.224,閘道器10.240.0.65,對端裝置路由表含192.168.10.0網段。route -p add 192.168.10.0 mask 255.255.255.0 10.240.0.65。路由器配置和電腦一樣,單詞不同。舉例:

    華為的路由器 ip route-static 192.168.1.45 255.255.255.255 10.10.10.1,到指定地址192.168.1.45,下一跳是10.10.10.1

  • 2 # 雲青晴

    靜態路由

    1、 拓撲圖

    2、 路由配置1

    interface FastEthernet0/0.1

    encapsulation dot1Q 10

    ip address 192.168.1.1 255.255.255.0

    !

    interface FastEthernet0/0.2

    encapsulation dot1Q 20

    ip address 192.168.2.1 255.255.255.0

    !

    interface FastEthernet0/1

    no ip address

    duplex auto

    speed auto

    shutdown

    !

    interface Serial0/0/0

    ip address 10.1.2.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/0/1

    ip address 10.1.3.1 255.255.255.0

    !

    interface Serial0/1/0

    ip address 10.1.6.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/1/1

    no ip address

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    ip classless

    ip route 172.16.1.0 255.255.255.0 10.1.6.1

    ip route 172.16.2.0 255.255.255.0 10.1.6.1

    ip route 172.17.1.0 255.255.255.0 10.1.3.2

    ip route 172.17.2.0 255.255.255.0 10.1.3.2

    ip route 172.18.1.0 255.255.255.0 10.1.3.2

    ip route 172.18.2.0 255.255.255.0 10.1.3.2

    ip route 10.1.1.0 255.255.255.0 10.1.2.1

    ip route 10.1.4.0 255.255.255.0 10.1.3.2

    ip route 10.1.1.0 255.255.255.0 10.1.6.1

    ip route 10.1.4.0 255.255.255.0 10.1.6.1

    ip route 10.1.5.0 255.255.255.0 10.1.3.2

    3、 路由配置2

    interface Serial0/0/0

    ip address 10.1.2.1 255.255.255.0

    !

    interface Serial0/0/1

    ip address 10.1.1.1 255.255.255.0

    !

    interface Serial0/1/0

    ip address 10.1.5.1 255.255.255.0

    !

    interface Serial0/1/1

    no ip address

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    ip classless

    ip route 172.17.2.0 255.255.255.0 10.1.5.2

    ip route 172.17.1.0 255.255.255.0 10.1.5.2

    ip route 172.18.1.0 255.255.255.0 10.1.5.2

    ip route 172.18.2.0 255.255.255.0 10.1.5.2

    ip route 10.1.4.0 255.255.255.0 10.1.1.2

    ip route 10.1.3.0 255.255.255.0 10.1.2.2

    ip route 192.168.1.0 255.255.255.0 10.1.2.2

    ip route 192.168.2.0 255.255.255.0 10.1.2.2

    ip route 172.16.1.0 255.255.255.0 10.1.1.2

    ip route 172.16.2.0 255.255.255.0 10.1.1.2

    4、 路由配置3

    interface FastEthernet0/0

    ip address 172.16.1.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface FastEthernet0/1

    ip address 172.16.2.1 255.255.255.0

    duplex auto

    speed auto

    !

    interface Serial0/0/0

    ip address 10.1.1.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/0/1

    ip address 10.1.4.1 255.255.255.0

    clock rate 64000

    !

    interface Serial0/1/0

    ip address 10.1.6.1 255.255.255.0

    !

    interface Serial0/1/1

    no ip address

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    ip classless

    ip route 192.168.1.0 255.255.255.0 10.1.6.2

    ip route 192.168.2.0 255.255.255.0 10.1.6.2

    ip route 172.18.1.0 255.255.255.0 10.1.4.2

    ip route 172.18.2.0 255.255.255.0 10.1.4.2

    ip route 172.17.1.0 255.255.255.0 10.1.4.2

    ip route 172.17.2.0 255.255.255.0 10.1.4.2

    ip route 10.1.3.0 255.255.255.0 10.1.4.2

    ip route 10.1.2.0 255.255.255.0 10.1.1.1

    ip route 10.1.5.0 255.255.255.0 10.1.4.2

    ip route 10.1.3.0 255.255.255.0 10.1.6.2

    ip route 10.1.5.0 255.255.255.0 10.1.1.1

    5路由配置4

    interface FastEthernet0/0.1

    encapsulation dot1Q 10

    ip address 172.18.1.1 255.255.255.0

    !

    interface FastEthernet0/0.2

    encapsulation dot1Q 20

    ip address 172.18.2.1 255.255.255.0

    !

    interface FastEthernet0/1

    no ip address

    duplex auto

    speed auto

    !

    interface FastEthernet0/1.1

    encapsulation dot1Q 30

    ip address 172.17.1.1 255.255.255.0

    !

    interface FastEthernet0/1.2

    encapsulation dot1Q 40

    ip address 172.17.2.1 255.255.255.0

    !

    interface Serial0/0/0

    ip address 10.1.3.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/0/1

    ip address 10.1.4.2 255.255.255.0

    !

    interface Serial0/1/0

    ip address 10.1.5.2 255.255.255.0

    clock rate 64000

    !

    interface Serial0/1/1

    no ip address

    shutdown

    !

    interface Vlan1

    no ip address

    shutdown

    !

    ip classless

    ip route 172.16.1.0 255.255.255.0 10.1.4.1

    ip route 172.16.2.0 255.255.255.0 10.1.4.1

    ip route 192.168.1.0 255.255.255.0 10.1.3.1

    ip route 192.168.2.0 255.255.255.0 10.1.3.1

    ip route 10.1.2.0 255.255.255.0 10.1.3.1

    ip route 10.1.1.0 255.255.255.0 10.1.4.1

    ip route 10.1.6.0 255.255.255.0 10.1.3.1

    ip route 10.1.1.0 255.255.255.0 10.1.5.1

    6、互相ping通

  • 3 # Geek視界

    靜態路由的設定分為以下兩種:

    主機的靜態路由

    交換機或者路由器的靜態路由

    主機的靜態路由

    用於雙網絡卡分別接入內網和網路,或者單網絡卡連線兩個網路,或者別的情況。。。

    Route add –p則是新增一個永久路由,不會因為重啟而丟失路由資訊。

    新增到主機的路由

    route add –host 192.168.1.2 dev eth0:0

    route add –host 10.20.30.148 gw 10.20.30.40

    新增到網路的路由

    route add –net 10.20.30.40 netmask 255.255.255.248 eth0

    route add –net 10.20.30.48 netmask 255.255.255.248 gw 10.20.30.41

    route add –net 192.168.1.0/24 eth1

    route add -net 125.210.0.0 netmask 255.255.0.0 gw 125.210.230.93 dev eth1

    route add -net 125.210.213.0 netmask 255.255.255.0 gw 218.108.250.193 dev eth0

    網路裝置的靜態路由

    網路拓撲圖如下所示,R1和R2透過靜態路由相連。

    配置路由器R3的靜態路由的配置

    路由器R2的靜態路由的配置

  • 4 # GuangWang

    配置IPv4靜態路由示例

    組網需求

    路由器各介面及主機的IP地址和掩碼如圖1所示。要求採用靜態路由,使圖中任意兩臺主機之間都能互通。

    圖1 配置IPv4靜態路由組網圖

    配置思路

    採用如下的思路配置IPv4靜態路由:

    首先配置各路由器各介面的IPv4地址,使網路互通。

    在路由器上配置到目的地址的IPv4靜態路由及預設路由。

    在各主機上配置IPv4預設閘道器,使任意兩臺主機可以互通。

    資料準備

    為完成此配置例,需準備如下的資料:

    RouterA的下一跳為1.1.4.2的預設路由。

    RouterB的目的地址為1.1.1.0,下一跳為1.1.4.1的靜態路由。

    RouterB的目的地址為1.1.3.0,下一跳為1.1.4.6的靜態路由。

    RouterC的下一跳為1.1.4.5的預設路由。

    主機PC1的預設閘道器1.1.1.1,主機PC2的預設閘道器1.1.2.1,主機PC3的預設閘道器1.1.3.1。

    操作步驟

    配置各介面的IP地址(略)

    配置靜態路由

    # 在RouterA上配置IPv4預設路由。

    [RouterA] ip route-static 0.0.0.0 0.0.0.0 1.1.4.2

    # 在RouterB上配置兩條IPv4靜態路由。

    [RouterB] ip route-static 1.1.1.0 255.255.255.0 1.1.4.1

    [RouterB] ip route-static 1.1.3.0 255.255.255.0 1.1.4.6

    # 在RouterC上配置IPv4預設路由。

    [RouterC] ip route-static 0.0.0.0 0.0.0.0 1.1.4.5

    配置主機

    配置主機PC1的預設閘道器為1.1.1.1,主機PC2的預設閘道器為1.1.2.1,主機PC3的預設閘道器為1.1.3.1。

    檢視配置結果

    # 顯示RouterA的IP路由表。

    [RouterA] display ip routing-table

    Route Flags: R - relay, D - download to fib

    ------------------------------------------------------------------------------

    Routing Tables: Public

    Destinations : 8 Routes : 8

    Destination/Mask Proto Pre Cost Flags NextHop Interface

    0.0.0.0/0 Static 60 0 RD 1.1.4.2 Pos1/0/0

    1.1.1.0/24 Direct 0 0 D 1.1.1.1 GigabitEthernet2/0/0

    1.1.1.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    1.1.4.0/30 Direct 0 0 D 1.1.4.1 Pos1/0/0

    1.1.4.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    1.1.4.2/32 Direct 0 0 D 1.1.4.2 Pos1/0/0

    127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0

    127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

    # 使用Ping命令驗證連通性。

    [RouterA] ping 1.1.3.1

    PING 1.1.3.1: 56 data bytes, press CTRL_C to break

    Reply from 1.1.3.1: bytes=56 Sequence=1 ttl=254 time=62 ms

    Reply from 1.1.3.1: bytes=56 Sequence=2 ttl=254 time=63 ms

    Reply from 1.1.3.1: bytes=56 Sequence=3 ttl=254 time=63 ms

    Reply from 1.1.3.1: bytes=56 Sequence=4 ttl=254 time=62 ms

    Reply from 1.1.3.1: bytes=56 Sequence=5 ttl=254 time=62 ms

    --- 1.1.3.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 62/62/63 ms

    # 使用Tracert命令驗證連通性。

    [RouterA] tracert 1.1.3.1

    traceroute to 1.1.3.1(1.1.3.1), max hops: 30 ,packet length: 40

    1 1.1.4.2 31 ms 32 ms 31 ms

    2 1.1.4.6 62 ms 63 ms 62 ms

    配置檔案

    RouterA的配置檔案

    #

    sysname RouterA

    #

    interface GigabitEthernet2/0/0

    ip address 1.1.1.1 255.255.255.0

    #

    interface Pos1/0/0

    link-protocol ppp

    ip address 1.1.4.1 255.255.255.252

    #

    ip route-static 0.0.0.0 0.0.0.0 1.1.4.2

    #

    return

    RouterB的配置檔案

    #

    sysname RouterB

    #

    interface GigabitEthernet3/0/0

    ip address 1.1.2.1 255.255.255.0

    #

    interface Pos1/0/0

    link-protocol ppp

    ip address 1.1.4.2 255.255.255.252

    #

    interface Pos2/0/0

    link-protocol ppp

    ip address 1.1.4.5 255.255.255.252

    #

    ip route-static 1.1.1.0 255.255.255.0 1.1.4.1

    ip route-static 1.1.3.0 255.255.255.0 1.1.4.6

    #

    return

    RouterC的配置檔案

    #

    sysname RouterC

    #

    interface GigabitEthernet2/0/0

    ip address 1.1.3.1 255.255.255.0

    #

    interface Pos1/0/0

    link-protocol ppp

    ip address 1.1.4.6 255.255.255.252

    #

    ip route-static 0.0.0.0 0.0.0.0 1.1.4.5

    #

    return

  • 中秋節和大豐收的關聯?
  • 川普二次彈劾以無罪結束案件,他該何去何從?